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Denotes a hierarchical menu

Note: Most of these menu items are dynamic and will 
change relative to the active context.

File Menu

New Alt+Shift+N
Open Path Ctrl+Shift+A
Open File
Close Ctrl+W
Close All Ctrl+Shift+W
Save Ctrl+S
Save As
Save All Ctrl+Shift+S
Revert
Move
Rename F2
Refresh F5
Convert Line Delimiters To
Print Ctrl+P
Switch Workspace
Restart
Import
Export
Properties Alt+Enter
Exit

Edit Menu

Undo Ctrl+Z
Redo Ctrl+Y
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Delete Delete
Select All Ctrl+A
Find/Replace Ctrl+F
Find Next Ctrl+K
Find Previous Ctrl+Shift+K
Incremental Find Next Ctrl+J
Incremental Find Previous Ctrl+Shift+J
Add Bookmark
Add Task
Show Tooltip Description F2
Word Completion Alt+/
Quick Fix Ctrl+1
Set Encoding

Source Menu

Toggle Comment
Add Block Comment
Remove Block Comment
Shift Right
Shift Left
Correct Indentation
Format
Add Include
Sort Lines

Refractor Menu

Rename
Extract Local Variable
Extract Constant
Extract Function
Toggle Function
Hide Method
Apply Script
Create Script
History

Search Menu

Search Ctrl+H
File
C/C++
Text

Project Menu

Open Project
Close Project
Build All Ctrl+B
Build Configurations
Build Project
Build Working Set
Clean
Make Target
Properties

Menus and Keyboard Shortcuts (some menus/items can be hidden in any perspective)

Eclipse Quick Reference Windows ® Hosted
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Window Menu

New Window
New Editor
Hide Toolbar
Open Perspective
Show View
Customize Perspective
Save Perspective As
Reset Perspective
Close Perspective
Close All Perspectives
Navigation
Refresh Debug Views
Preferences

Help Menu

Welcome
Help Contents
Search
Dynamic Help
Key Assist Ctrl+Shift+L
Videos
Tips and Tricks
Cheat Sheets
Check for Updates
Install New Software
Documentation 
About CodeWarrior Development Studio
Freescale Licenses

Menus and Keyboard Shortcuts (Continued)

MQX Tools Menu

Attach to target
Detach from target
RuntimeTAD Preferences
Performance data viewer
Stack Usage
CPU Usage view
Timeline view
MQX Tools documentation

Processor Expert Menu

Show Views
Hide Views
Import Component(s)

Run Menu

Instruction Stepping Mode
Move to Line (C/C++)
Resume At Line (C/C++)
Resume
Suspend
Terminate
Disconnect
Resume Without Signal
Step Into
Step Over
Step Return
Run to Line
Run Ctrl+F11
Debug F11
Run History
Run As
Run Configurations
Debug History
Debug As
Debug Configurations
Toggle Breakpoint Ctrl+Shift+B
Toggle Line Breakpoint
Toggle Method Breakpoint
Toggle Watchpoint
Skip All Breakpoints
Remove All Breakpoints
Breakpoint Types
Reset
Multicore Resume Alt+Shift+F8
Multicore Suspend
Multicore Restart
Multicore Terminate
External Tools

Denotes a hierarchical menu

Note: Most of these menu items are dynamic and will 
change relative to the active context.
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1. Welcome page—the first page you see when 
you launch Eclipse IDE for the first time

2. Launches the New Project wizard

3. Starts CodeWarrior Project Importer wizard. 
You can use the Eclipse Import Wizard to 
import example projects into your work-
space.

4. Takes you to the Workbench window

5. Welcome page toolbar. Toolbar options 
include (from left to right):

• Home
• Navigate to previous topic
• Navigate to next topic
• Reduce
• Magnify
• Customize page
• Minimize
• Restore

6. Gives you information about the major new 
features in this release of the product

7. Takes you to 
freescale.com/codewarrior
3

8. Takes you to the Tutorials page that pro-
vides links to the Cheat Sheets, Getting 
Started guide and Help system

Tips and Tricks

• To return to the Welcome page or to 
access the Welcome page from the 
Workbench window, select Help > 
Welcome from the IDE menu bar.

• To customize the Welcome page, click the 
Customize page icon in the Welcome 
page toolbar. In the Customize dialog box, 
click the appropriate tab and make the 
required changes.

   *   Depending on the product you are work-
ing with, there may be a slight variation in 
the screenshot of the Welcome page 
above and/or the screenshots on page 3-
10 of this card.



Workbench Window-C/C++ Perspective
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1. Workbench window
2. Workbench menu bar
3. Workbench toolbar containing com-

mands for C/C++ perspective
4. CodeWarrior Projects view
5. CodeWarrior Projects view toolbar
6. Problems view
7. Perspective switcher. Toolbar options 

include (from left to right):
• Open perspective
• C/C++ perspective

8. Editor area
9. Outline view
10. Tabbed views or View stack (Problems, 

Console, Tasks, Remote Systems, and 
Properties views)

11. Toggle visibility of details pane
12. Problems view pull-down menu. Menu 

options include:
• Show
• Group By
• Sort By
• New Problems View
• Configure Contents
• Configure Columns

13. Click to minimize the View stack (in this 
case, for the Problems view)

14. Click to maximize the View stack (in this 
case, for the Problems view)
Tips and Tricks

• To activate a view that is part of a tabbed view or 
view stack, click its tab.

• Press Ctrl+F6 to switch between editors, 
Ctrl+F7 to switch between views, Ctrl+F8 to 
switch between perspectives, and F12 to acti-
vate the editor.

• To see a complete list of the currently available 
key bindings in the editor or view you are cur-
rently working with, press Ctrl+Shift+L.

• To quickly import files and folders to your work-
space, drag them from the Windows file sys-
tem to a view, such as CodeWarrior Projects 
view. Similarly, to export files and folders, drag 
them from a view to the Windows file system.

• To change the default way perspective opens 
in the Workbench window, such as to open it in 
a different window, use the Open a new per-
spective options in the Window > Preferences 
> General > Perspectives page.

• Right-click the title of a view to: 
• Display it as a fast or detached view 
• Restore or move the view 
• Minimize, maximize, or close the view 
• Size the view to left, right, top or bottom
4
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Workbench Window—Debug Perspective
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Tips and Tricks

• To open other views in a perspective, 
select Window > Show View > Other 
and select a new view from the Show 
View dialog box.

• To save the changes made in the cur-
rent perspective, select Window > 
Save Perspective As.

• To return the perspective to its original state, 
select Window > Reset Perspective.

• To open a new perspective, select 
Window > Open Perspective > Other 
and select a new perspective from 
the Open Perspective dialog box.

1. Workbench toolbar containing commands 
for Debug perspective

2. Debug view

3. Debug view toolbar

4. Editor area

5. View stack (Variables, Registers, Break-
points, Memory, Modules)

6. Variables view

7. Console view
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Editor Area
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Tips and Tricks

• To open a list of all open editors and quickly 
switch between editors, press Ctrl+E.

• You can open a file in the editor 
area by dragging the item from a 
view, such as CodeWarrior 
Projects or Project Explorer and 
dropping it over the editor area.

• To activate single-click opening for 
editors, use the Open mode options in 
the Window > Preferences > General 
page. In single-click mode, a single-click 
on a file selects and immediately opens 
the file.

• Double-clicking in the marker bar 
(2) sets or removes breakpoints.

• To move lines up and down in the 
editor, press Alt+Arrow Up and 
Alt+Arrow Down.

• To view two or more sections of a source 
file at the same time, open a similar editor 
using Window > New Editor. Drag the new 
editor tab and drop it over the left, right, 
top, or bottom border of the editor area.

• To activate code completion, press 
Ctrl+Space.

• To activate quick diff, right-click the 
markerbar (2) and select Show Quick 
Diff from the context menu.

• When the mouse cursor is placed over a 
change in Quick Diff (1), a hover displays 
the original content, which can be 
restored using the marker bar context 
menu.

1. Quick diff, which displays color-coded 
indication for additions, deletions, or 
changes made to the contents of a file

2. Marker Bar

3. Auto Breakpoint

4. Hardware Breakpoint

5. Software Breakpoint

6. Disabled Breakpoint

7. Bookmark Marker

8. Warning Marker

9. Task Marker

10. Indexer Marker

11. Error Marker

12. An asterisk (*) appearing at the left side 
of the tab indicates that the editor has 
unsaved changes

13. Icons that flag error, warning, task and 
bookmark markers. You can view extra 
information by placing the mouse cursor 
over the marker



Debug Configurations Dialog Box
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1. Toolbar options include (from left to right):
• New launch configurations

• Duplicates the currently selected launch 
configuration

• Delete selected launch configuration(s)

• Collapses all expanded launch 
configurations

• Filter launch configurations

2. Type text to filter the launch configurations

3. List of launch configurations that apply to the 
current application. CodeWarrior generates 
launch configurations with names that follow 
the pattern projectname-configtype-target-
type

4. Specifies the name of launch configuration 
selected in the list (3)

5. Click to maximize the View stack (in this 
case, for the Problems view)

• Main: Identifies the project and application 
you want to debug

• Arguments: Specifies the program 
arguments and working directory that an 
application uses for a debug configuration
• Debugger: Specifies the debugger to use 
when debugging an application

• Source: Specifies the location of source 
files used when debugging an 
application

• Environment: Specifies environment 
variables and values to use when an 
application runs

• Common: Specifies the location in which 
to store the run configuration and how to 
access it, how standard input and output 
is handled, and if background launches 
are enabled or not

• Trace and Profile: Specifies the trace and 
profiling options required for hardware 
profiling

6. Click to debug the selected launch config-
uration
7
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Preferences Dialog Box
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1. Type text to filter the preference panels

2. Select a preference panel from the hierarchi-
cal list to view and edit its settings on the 
right. The collection of panels varies, 
depending on the current build target and 
chosen settings

3. Allows you to navigate through the previously 
viewed pages

4. Edit preference settings in this panel

5. Restore default settings

6. Save settings for the current project
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Help View
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Tips and Tricks

• To open the Help view, select Help > 
Dynamic Help or Help > Search.

• You can press F1 to activate 
context-sensitive help.

• Help window—You can also access the 
help system in the Workbench window 
using the Help window, which opens as a 
separate window. To open the Help 
window, select Help > Help Contents.

1. Help view

2. Click to display a list of all the help topics 
provided with the IDE

3. Click to activate the Help documentation 
search functionality

4. Click to view the related help topics

5. Click to view an index of the help 
documentation

6. Click to view the bookmarked help topics
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Cheat Sheets
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1. To launch a cheat sheet in the Workbench 
window, select Help > Cheat Sheets

2. From the Cheat Sheet Selection dialog box, 
select the cheat sheet you want to open

3. Follow the steps given in the cheat sheet to 
perform a particular task, such as Changing 
P&E Connections Setting.
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Other Tips and Tricks

Search Dialog Box

• You can open the Search dialog box by 
clicking on the Workbench toolbar or 
using the Search menu

• The File Search tab allows you to search 
for files or text in the Workbench

• The C/C++ Search tab allows you to 
search C/C++ elements, such as class, 
struct, function, variable, union, field, 
enumeration and namespace

• The search functions support the following 
wildcards: Use * to represent any series of 
characters Use ? to represent any single 
character Use \ to represent literals, such 
as \*, \?

Properties Dialog Box

• You can open the Properties dialog box by 
right-clicking a project in a view, such as 
CodeWarrior Projects or Project Explorer, 
and selecting Properties from the context 
menu

• The left pane of this dialog box has a Prop-
erties list. This list shows the build proper-
ties that apply to the current project

• You can use the right pane to modify the 
build properties of the project, as required. 
For example, to set properties for linker, 
assembler, and complier, select C/C++ 
Build > Settings in the left pane. You can 
make the required changes in the Tool set-
tings page in the right pane

Miscellaneous

• To rename an object in a project, such as 
class and type name, variable, and method, 
right-click on the object in the editor area and 
select Refactor > Rename or press 
Alt+Shift+R. The refactoring engine renames 
all instances of the object in all referenced 
files. You can undo refactoring by right-
clicking the object again and selecting 
Refactor > Undo

• To set software and hardware breakpoint, 
right-click the marker bar in the editor area 
and select Set Special Breakpoint > Software 
or Hardware respectively

• You can link the navigation views, such as 
CodeWarrior Projects and Project Explorer, 
with the editor to automatically activate the 
file in editor every time you select that the file 
in the view. To link the view to the editor, click 

in the view toolbar

• To open a file in a different editor other than 
the default editor, select Open With from the 
file’s context menu and select the required 
editor

• To restore a maximized view, click the 
icon.

Learn More: For more information about 
Freescale products, please visit 
www.freescale.com/codewarrior.
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